6-60 6-39 6-38 Downgrader PSP

From GameBrew

6.60/6.39/6.38 Downgrader
Psp2.png
General
Authorsome1
Last Updated2011/08/27
TypeSystem tools
Version4.1
LicenseMixed
Links
Download
Website

6.60/6.39/6.38 Downgrader is a port of Davee's 6.60/6.39/6.38/6.35/6.31 Downgrader for PSP. The application is made by Some1 and allows user to downgrade to 6.20 using the Sony Updater on all PSPs.

Version 3.5 was submitted to the PSP Genesis Competition 2011 (Main prizes 3rd place).

Installation

You will need the following:

  • 6.20 Firmware updater (official).
  • 6.60/6.39/6.38 Downgrader by some1.

The downgrader is signed and can be launched from OFW XMB. To install, copy the official 6.20 updater in (ms0:/ or ef0:/ for PSPgo)PSP/GAME/UPDATE/EBOOT.PBP.

After setup run the downgrader, this will reboot into the 6.20 update, and allow you to downgrade to 6.20 (follow the onscreen instructions).

Important note from developer:

You run the application at your own risk.

After you downgrade to 6.20, you will get a BSOD (saying that your system information is corrupted), click Circle to reset your system information and you will be back to normal.

Compatibility

Works on all PSPs with FW6.39, 6.38, 6.35, 6.31 (PSP-1000, 2000, 3000, Go).

Among them, 07g and 09g model of PSP-3000 is downgraded to FW6.35 only. Other models support downgrade to FW6.20, FW6.35.

Changelog

v4.1

  • Added Source Code.
  • Added Safety net just in case, for some reason, your psp does not have the 0x51 key, the safety net sets minimum version to 6.35 if you were getting an error from v4.
  • Includes Proxima's prxencrypter with gzip support.

v4.0

  • Added Support for 6.60.
  • Fixed 6.60 problem that didn't allow to downgrade to anything greater than 6.20, thanks to Davee.
  • Allows any updater that is greater than or equal to the factory installed OFW (Has not been fully tested, will most likely work on 500 and up).
  • Special Sauce added by Proxima.

v3.5

  • If the 6.20 updater MD5 check fails, it will check if the update file is 6.35, allowing non 07g/09g to downgrade to 6.35, added source, removed a few debug printf's.

v3.1

  • Fixed bug for 6.38 when adding 6.39.

v3

  • Added support for 6.39, added model printer.

v2

  • 09g/07g Support added.

Credits

Davee for making the original 6.35/6.31 downgrader.

ultimakillz, skyend, n00b81, Davee, Freddy, TheLemonMan, Hellcat, Draan, TiPi, Nymphaea, Npt, Arnold and all the people who beta tested.

External links