Luma Updater 3DS

From GameBrew

Revision as of 12:10, 7 February 2022 by HydeWing (talk | contribs) (→‎External links)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Luma Updater
Lumaupdaterkun2.png
General
AuthorKunoichiZ
Last Updated2021/03/08
TypeSystem Tools
Version2.6
LicenseWTFPL
Links
Download
Website
Source

Luma Updater, formerly known as ARN Updater, is a boot.firm updater for Luma3DS and boot9strap (formerly AuReiNand) as a 3DS homebrew (no more SD swaps).

Features

  • Update the boot.firm file from Luma3DS on your SD card and your CTRNAND, if you followed Plailect's guide.
  • Back up your current boot.firm on your SD card (and CTRNAND when allowed to) to boot.firm.bak.
  • Restore your old backup of boot.firm on your SD card root (and CTRNAND when allowed to).
  • Block all updates from Luma3DS v7.1 as that only supports boot9strap v1.0/v1.1. Luma3DS v8.0+ only supports boot9strap v1.2+.

User guide

Originally from Hamcha's wiki.

For boot9strap Users:

  • Install Luma Updater's CIA then launch it.
  • Select latest stable version.

For HBL/Rosalina Users:

  • Enable Patch ARM9 access in your Luma3DS configuration (may not be needed depending on your Luma version).
  • Launch the HBL then Luma Updater.
  • Select latest stable version.

Changelog

v2.6

v2.5

  • This update fixes the error in #49, #50, and #51 and closes #49. This update should now allow you to download Luma3DS and any future releases of Luma Updater.

v2.4

  • Added support for Luma3DS v10.0.
  • Huge major credits to @hax0kartik for his help with coming up with a fix.
  • All outstanding issues (includes #43, #45, and #47) have been fixed as of 11:12 PM Central Standard Time on 6/29/19.

v2.3

  • Added support for Github TLS v1.2 (credit to @Pirater12).
  • Hopefully fixes auto-updating.
  • Huge major credits to @Pirater12, @saibotu, and @angelsl for their help coming up with a fix.

v2.2

  • Removed the latest hourly build text. Why? You can no longer install the latest hourly with the latest version of Luma Updater to the text is useless and therefore has been removed.
  • Changed the display text at the bottom of the top screen.
  • The following is credit to @chenzw95:
    • Block all updates from Luma3DS v7.1, which is only compatible with b9s v1.0/v1.1. This is to help with people updating to Luma3DS v8.0+ without updating b9s first.
    • Show error codes in hex, for consistency across apps.
    • Allow users to restore any backups if they have no internet connection.
    • Removed the path changer code because Luma3DS no longer uses it.

Release notes.

Credits

External links